2020年06月29日

久しぶりに、メガCD1のメンテをしました^^

いつもお世話になってる方から、
メガCDをメンテしてくださいとのことで^^
久しぶりに腕を振るう時がついにやってきました(笑

最近はスマホでスタリラばかりやっていますので^^;
課金すればするほど強キャラが取れて、見ず知らず人との対戦が面白くなる課金ゲーですが・・・
正直、課金ゲーはいくらお金あっても足りませんのでお勧めしません。

早速メガCDを見てみます、
特にメガCD1を触るのは久しぶりです。
早速、動作確認したのですがトレイが出てきて、
CDを入れたものの読み込みませんでした、、

動作確認済みで動きますと言っていたはずなのに・・・あれれぇ^^;
これは、どうしたものかと思い本体を逆さまにしたら、読み込めました(笑
ベルトが滑ってギュイーンと空回りする音がしてましたので、
内部にある機構が上がらず、レンズがCDを読み込めなのだなと思い、
単純にベルトが伸びてるだろうなと思いました。

中をみてやはりベルトがゆるゆるで甘いです。。。
ベルトがユルイです.JPG


当然、伸びてました。
ベルトが伸びて癖がついてまさす.JPG


右の新品ベルトへ交換しました。大きさはφ25×1.6Tぐらいだったかな。
右の新品ベルトに交換しました.JPG



コンデンサー交換前で結構漏れてました、ギリギリ間に合ってよかったと思います。
茶色の飛び散ったものが電解液です、これが乾くと腐食したりパターンが破損したり、通電しなくなります。
コンデンサー交換前、かなり漏れてます.JPG



コンデンサー交換後です、バックアップ電池もホルダ化して容易に交換可能な状態にしました^^
コンデンサー交換後、バックUP電池も交換済みです.jpg


これで一安心です、メガCD1はいくつかロットがあって、
このロットはコンデンサーが少ないと思われましたので、
それもあって助かったのかと思います^^
手遅れになると電源基板の部品が徹底的に4級塩コンデンサーが漏れまくり、復旧不能な状態にまでになりますーー;
posted by はにはに at 15:23| Comment(48) | ゲーム機 | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
メンテお疲れ様です。

自作PCのDVDドライブが音楽CDの取り込み後
再生時に雑音が乗るのでレンズクリーニングしました。

まあー無事復活しました。


開腹したらゴムベルトが使用されていました。
あーこれがバカになるんだなと観察していました。

経年でゴムベルトがバカになったら、もう処分かなとw
どうせ大陸の安い奴だしw

全然関係ないけどw
Posted by ぽにー at 2020年06月29日 23:49
レトロゲーム修理の内容に感動しました。
私も音の出なくなったワンダーメガがあるのですが
修理の依頼など出来るのでしょうか?
Posted by ネオン at 2020年06月30日 02:40
ぽにー様^^
お世話になっております^^

レンズグリーニングはとても大事ですね〜!
ベルトは20年もしたら、当然伸びまくりのガバガバですね(w

Posted by はにはに at 2020年06月30日 18:52
ネオン様^^
ワンダメガの音が出なくなる症状は直せます。
どうしても音声部のコンデンサーは容量が小さいので抜けるんですよね。。。
こちらまでご連絡くだればと思います。
slash0zero@gmail.com
Posted by はにはに at 2020年06月30日 18:56
はにはにさん、お久しぶりです。
私の事を憶えておりますでしょうか??(笑)
メガCD1の修理とは、これまた難しい機種ですね^^;
(これは最終バージョンから1つ前くらいの型かな??)

私含め、レトロ機の修理を行える者は何人も居られますが、何故か、はにはにさんが修理を施した機体はとても輝いて喜んでいる感じが私にも伝わります。o(*^▽^*)o
その・・非常に言い難いんですが、もうヤフオクには参戦されないんですか?
MSXと言えば、はにはにさんの印象なので、私的に・・。
久しぶりにMSXカテを見て、はにさんが居られなかったので非常に寂しく感じました・・。

私も人の事を言えれませんが、ヤフオクやめて5kgくらい太りました(笑)
でも、自分の時間が取れるようにはなったかな^^;
Posted by Z at 2020年07月07日 15:39
( ゜Д゜)ゞ お疲れ様です
私も現在、以前直したメガCDと格闘中です。
動いていたのですが、途中でハングアップする事が多々あり、めぼしい所の半田を溶かしてみたのですが症状が悪化。
とりあえず以前ネットで入手した回路図を元に、原因と思しき所を一つづつ潰す作業に入りました。
今、電源基盤が終わるところですが、驚いたのが三端子レギュレーターのパターンを探ろうとランド付近のソルダレジストを削ってみたら、メガCDの電源基盤(SUBボード)は二重パターンになってました。(MAINボードもそうでしょう)
本来のパターンの上にソルダレジストを乗せ、さらにシールドパターンが印刷されていました。
なので削るとシールドパターンが雲のような斑になってしまいましたσ(・ω・`;)
本パターンが守られやすい(つか、液漏れ前提なのか?電波シールド?)のですが、下手に削るとショートしそうで怖いですwww
Posted by at 2020年07月11日 19:53
ちなみに、私のメガCDは学生の頃に買った初期型なので、はにはにさんの写真よりも古く、水晶発振器が二階建てになっているタイプです。
故障の原因は回路図から大体推察出来ていて、おそらく2番ICのセガカスタムチップ315-5548だと思われます。(足が腐食しだしている)
このIC2がメガCDのエンジンで、68000などのコントロールを行っています。
RAM関係も睨んでいましたが、途中まで動いてからのハングアップなので68000の暴走だと踏んでいますが68000では無いと見ています・・・
Posted by at 2020年07月11日 20:14
ヽ( ̄ー ̄ )ノ動きましたw
電源部分の三端子とヒートシンクを外し、21ピンのコネクタを外し、全部清掃し直してから組み上げて持ち帰って動作確認したら動きました。
最初は雲の絵で止まってたんですが、どうやら32Xの半挿し?が悪さをしていたようです。
ただ、メガCDを外した状態(メガドライブ&32X状態)で海賊版テトリスが止まったので、32Xが怪しくなってきました。(もしくはメガドライブのカセットスロット)
とりあえず32Xをバラしてコンデンサ関連を交換してみます。
Posted by at 2020年07月12日 02:49
Z様^^

お世話になっております。
覚えておりますよ^^
体調も微妙なことがありしばらくはお休みさせていただきます。
コロナも人数が増えているため、まだまだ自粛ですね。。。
Posted by はにはに at 2020年07月12日 10:23
営様^^

メガCDもいろいろなタイプがあって、
壊れやすいのが沢山あって困りますね^^;

>電源部分の三端子とヒートシンクを外し、

その三端子の電源部が液漏れで非常に壊れやすいですが、組み上げて直ったのであれば本当に良かったです

更に32Xが悪さしていたようで・・・
32Xはコンデンサー交換したことありますが4級塩ではなかったような気がします。
Posted by はにはに at 2020年07月12日 10:30
( ゜Д゜)ゞ お疲れ様です
今日32Xを開けてみました。
まあ、盛大にホコリが積もっていたので掃除と、メガドライブに挿さるメイン基板(カセット型のCPUが乗っている方)の端子が黒かったので、これの清掃を行いました。
32Xの挿し直しでハングアップが無くなったので、原因は端子の汚れと判断し、コンデンサ交換はやめましたwww
とりあえずコンデンサデータを取っておきました。ブログに8/12予約投稿で上げます。
ちなみにメガCDの図面は今日付けの記事で上げてありますので良かったら使ってください。
Posted by at 2020年07月12日 21:13
(; ̄Д ̄)お疲れ様です
またメガCDが逝きました・・・(時々動こうとしたり、音も流れるので完全には死んでません)
原因は後二つしか考えられません・・・
VCC2を安定化させている16V100μF2個(メイン基板実装)を中古のものでやっちゃったので、本日千石電商で買ってきました。
これでもダメならエンジンの足(0.5oピッチ)の半田付けしかないかな・・・
三端子については調べ方が分かり、メガドラタワーの状態で32Xのスペハリを動かした時の音と、メガCDのコネクト部分だけを外した場合の音ではレベルが違います。
音がメガCDの音声アンプ経由で出ており、この電源はVCC2から作られているAVCCなので、三端子が死んでる、もしくは繋がっていない場合には32Xの音声増幅がメガCDで成されません。
なので三端子は生きてるって判断です。

さてと・・・難しくなってきましたwww
中古の100μFを変えて改善しない場合は、精密半田作業に成っちゃいますwww(意外と楽しんでますw)

( ゜Д゜)ゞ それでは失礼します。また結果が出たら御報告します。
Posted by at 2020年07月13日 23:10
営様^^
一応動かなくなったとはいえ^^;
画面でたりしてるならまだダイジョブそうですね・・・
三端子が問題ないようであれば100μFを変えてみてあうとなら、まずそうですね^^;
またご報告お待ちしております。
Posted by はにはに at 2020年07月14日 11:33
私も最近MEGACDの修理をしていました。
コンデンサ全交換でシルフィードで動作確認
やった動いた!と思い次にゆみみやってみると
あれ?BGMは鳴るけどOPの歌が流れない?
なんかCD-DAだけ鳴らない症状でした。シルフィードではわからない訳だw
もう一台の正常なMEGACDとサブ基板、CDユニット交換したらCD-DAは鳴ったのでメイン基板が原因のようです
やはり腐食でどこか断線ですかねぇ
Posted by すぱお at 2020年07月15日 07:13
補足)正常なMEGACDメイン基板にCD-DA出ない機体のサブ基板とCDユニットを付けてみたら正常に音が出たですね
Posted by すぱお at 2020年07月15日 07:18
( ゜Д゜)ゞ お疲れ様です途中経過報告です
とりあえず、本日コンデンサを交換しました。
ですが、現象は変わらず。
電源を入れる度に症状が変わります。
1雲の画面で止まってOPが流れる
2映像がカクカクしてOPが流れる
3電源が入らない
4画面が黒いままでOPだけ流れる
以上からブートROMのIC4は生きているし、電源も問題無いので、やはりIC2のMEGACDエンジンの足腐食が原因でしょうねえ。
σ(・ω・`;)半田盛り直しで改善すれば良いですが、パターン的にICの下のVIAで繋がっている部分もあるので、そこが腐食していたらお手上げですな・・・
Posted by at 2020年07月15日 20:30
すぱお様、
メガCDは本当に厄介ですね^^;
4級塩の液漏れが原因で腐食して断線してるのかもしれませんね。。。
Posted by はにはに at 2020年07月16日 00:58
営様^^
お疲れ様です〜
コンデンサー交換してもダメでしたか・・・^^;
電源入れるたびに症状が変わるとは。。。
やはり足が腐食してると厳しそうですね^^;
半田盛して吸い取っての繰り返しで綺麗にしていくのですが、なかなか難しいですね。
明日は液漏れしたゲームギアに挑戦します。
Posted by はにはに at 2020年07月16日 01:03
はにはに様
ホント4級塩はやっかいですよね
見た目だけではビアに侵入して断線してるのもわからないですし・・

今度ゲームギアも修理なされるそうで
こちらも腐食が厄介です
うちのやつの一台はアルコールで基板拭いてたら
チップコンデンサと抵抗がポロリしましたよ‥
Posted by すぱお at 2020年07月16日 08:30
すぱお様^^

本当に4級塩は漏れた時はまだよいのですが、
漏れて乾くと基板の奥底に入り込んでしまいますので、何をしてもダメということが多いですね^^;
腐食が本当に厄介ですね、
漏れた4級塩がチップ抵抗にまで浸食ですからね、綺麗にしてるだけでポロリはよくあることです^^;
Posted by はにはに at 2020年07月16日 15:18
( ゜Д゜)ゞ お疲れさまです
今、MAIN基盤のIC2半田盛り直しに着手しました。
二階部分を外してみて、改めて分かったこと。
1 IC2用VCCコンデンサC23付近の浸食が激しい。
2 1MbitワークRAM用VCCコンデンサC28,C31周りの浸食が激しい。特にC28(IC11用VCC)付近のソルダレジストを剥がしたら、茶色い液体(電解液)が出てきた。
以上から、原因はIC2では無くワークRAMかも知れません。
まあ、一応IC2の浸食方向側は半田盛り直しを実行して結果を後程書き込みます。
Posted by at 2020年07月21日 16:55
( ゜Д゜)ゞ お疲れ様です
σ(・ω・`;)うーん、むずかしい・・・
とりあえず今回の処置では、1 雲の画面で止まってOPが流れる。に固定されました。
IC2は0.3oピッチでしたね。やってみてメッチャ難しい・・・
何本か足が曲がり、ランドが剥がれた個所が1つ。ICの下なので切れてるかどうかは不明。
パターンを辿るのは無理なので、資料のパターンデータから(必要であればブログに上げます)から直接IC下のVIAに裏側から接続するか・・・
1MbitワードRAM当たりのシールドパターンも全部剥がしてみる必要が有りそうです。
これが直せたら、何でも直せる気がしますw
Posted by at 2020年07月22日 14:10
営様^^

0.3mmピッチは難しいですね・・・
拡大鏡使っても老眼で見えにくい^^;
パターン辿るのは無理でしょうね((+_+))
Posted by はにはに at 2020年07月22日 14:38
( ゜Д゜)ゞ お疲れ様です
ようやく原因らしき物が見えました。
1M bit WORD RAM 0/1(IC11/12 ICデータを調べてみるとVRAMでした)のVCC用コンデンサがC28/C31なのですが、パターンを見るために一度外してランド周りのソルダレジストをコリコリ削って行ったら、C31のマイナス側のパターンがキレイに分断してましたw
(回路図から見るとIC12の方ですね)

やはりMAIN基盤も二重パターンで本命回路の上にシールド兼GNDパターンが印刷されていました。
C28周りのシールドパターンは腐食で分断されたのでジャンパー。C31の分断した所もジャンパーしてGNDラインを確保しました。
VIA関係は、腐食が激しい周りの貫通タイプを0.5o錫メッキ線を通してコシコシ磨き、表面が黒いものは銅箔面が見えるまでデザインナイフでコリコリ削る。黒く埋まってるVIAは積層基盤では無い事が分かっているので、0.5oのピンバイスで半田の銀色が見えるまで削り込む感じで処置(まあ、貫通させても良いのですが)

以上のような工程になりました。作業は事務所兼工作場でやってるのですが、これで家に持ち帰って動けば勝ちかなぁ???
(; ̄Д ̄)やっと見えてきたかも。
Posted by at 2020年07月29日 18:33
( ゜Д゜)ゞ お疲れ様です やり直してますwww
騙されました。シールドパターンの下に別途グランドパターンが有りました。
よって、C31は分断されておらず原因では無かった・・・
VIAの清掃で直るかどうか?って所になってきました。
Posted by at 2020年07月29日 22:02
(; ̄Д ̄)お疲れ様です
変化なかったです・・・ただ、生きは良くなってるらしく雲の画面でOPが流れる固定は変わってません。手ごたえはあるんですよね。
IC2のエンジン足を一部やり直してみるのと、ランドが剥がれた足がICの下で切れている事を想定してパターン資料からVIAにジャンパーを試してみます。
Posted by at 2020年07月30日 22:47
営様^^
お疲れ様です。
事務所兼工場だと作業も捗りそうですね、
うちの場合は自宅なのでモニターとかの内部清掃とか地獄です^^;

結局C31は原因ではなかったようで・・
VIAにジャンパー飛ばすのも大変そうですね^^;
それでうまく直ると良いのですが・・

メガCDは甘くないですね、
メガLDのパックも4級の液漏れで不具合ばかり出て地獄ですが^^;
Posted by はにはに at 2020年08月02日 02:26
( ゜Д゜)ゞ お疲れ様です
IC2をやり直すために、現在×10〜25まで拡大出来るLEDライト付き眼鏡型ルーペを発注しました。
4級塩の液漏れが想定内だったのか、とにかくシールドパターンが邪魔ですね。パターンが見えないw
回路図はあるのでパターンを追っていくことは可能なのですが、見えないのがツライwww

ウチのCLD-100は買ってきたゴムベルトを変える前なので、時々読み込みエラーは出ますが、PAC-S1はすこぶる調子が良いです。パターンも見えるのでPAC-S1の方が直しやすいかも?(回路図があれば、さらに確定で直せるのですけどねえ・・・)
Posted by at 2020年08月02日 22:48
営様^^
お疲れです!
細かいところをやるには、ルーペは必須ですね。
4級塩の漏れが想定外だったようで、
見えないのは辛いですね^^;

PAC-S1は調子が良いようで本当に良かったですね。まぁ運しだいなところもありますが^^;


Posted by はにはに at 2020年08月06日 22:13
( ゜Д゜)ゞ お疲れ様です
本日、おそらく最後になるであろう処置を施しました。
二階部分を外してIC2を調べましたが足がランドから外れているところは無く(拡大ルーペで確認しつつデザインナイフで触って動かないか全ピン確認)ショートも無し。
剥がれたランドのピンは93番のCT系統INTと言うピンで回路図を見るとCDエラーコレクションのIC(LC8951)に行っている事が判り、これが断線と言うわけでは無いと分かりました(雲の画面で固まると言うことはCDドライブ起動前で有る為)

ブログに上げたパターン図は1992年の171-6105C-01と言う基盤の物(おそらく、はにはにさんが処置したVer)でウチの初期型は1991年製171-6103Bという基盤でした。なのでライトで透かしながらパターンを確認していくと、やはりパターンの作りが違いました。

では何が原因だったんだろう?と二階建てを外した下や他のVIAも清掃をしました。
(今回は0.4oピンバイスにしました。それでも0.5o錫メッキ線は通ります。0.5oでやると微妙にVIAの銅が削れていることが確認できました)
そして分かってきたことは、やはり例のC28/C31のVIAが原因じゃないか?と言うこと。
パターンが違うためC28/C31のプラス側はVIAだけで繋がっている状態(1992年版は補助パターンが追加されている)でしたが、そこが一番液漏れが激しく液が残っていた所。
一旦直って動いたメガCDが時間経過で死んだので、症状が進行したと推測すると、ここのVIAくらいしか原因が思いつかない所まで追い込みました。
処置としてはプラス側のランドに繋がるVIAをピンバイスで貫通させ、0.5o錫メッキ線を通し、裏側のソルダレジストを剥いだVIA周りのプラス電源パターンに半田付けするというもの。
つまりVIAが内部分断している事を想定したVIA内ジャンパーって事です。

(;゜Д゜)これで持ち帰ってダメだったら、もう私には分かりません・・・チップ部品やICの故障となりますし・・・今回は勝ちたいwww
Posted by at 2020年08月08日 18:37
・゚・(ノД`;)・゚・ お疲れ様です。ダメでしたぁ・・・

ただ、何も変化が無かったか?と言うと、そうでもなく最初バグった雲の絵(ファミコンのROMを半挿しした時みたいな大きなドット模様)が出ました。
これはおそらく1M bit WORD RAM 0/1(IC11/12)の電源用コンデンサが繋がったためかと。
二回目の電源投入で雲の絵固定でOPが流れる状態にに復帰。

・・・こうなると前回やらかしたIC2(メガCDエンジンの315-5477)の93番pin(ICデータからI
INT でI/OはI)からIC15(LC8951)の51番pin(回路図からも1992年版パターン図からも確認済み)に直接ジャンパーしてどうか?って所ですかねえ・・・(CDドライブからのINT信号を貰わないと止まる?)
それでも変化が無ければ電解コンデンサ周りで変色しているVIAをシラミつぶしでVIA内ジャンパーしていくしか無くなりました・・・
Posted by at 2020年08月09日 01:50
σ(・ω・`;)お疲れ様です
再度入れなおしたら、以前と似た状況に戻っていました。
電源を入れる度に症状が変わります。
1雲の画面で止まってOPが流れる
2映像がカクカクしてOPが流れる(今回は出ず)
3電源が入らない(赤緑のランプが点かない)で黒い画面に縞模様のノイズが乗っている
4画面が黒いままでOPだけ流れる
5音楽は流れないがしばらくすると雲の静止画が出る。

難しくなってきました・・・
今回触った所で関わるとしたらIC2のエンジンですが、音関連やブートROMに関わるpinは触っていません。
音関連のほとんどはSUBボードの方なので、もしかしたらSUBボードも見直しつつVIAの修復って感じになるかも知れません。

(´Д`)絶対に直したいです!www
Posted by at 2020年08月09日 02:40
( ゜Д゜)ゞ お疲れ様です
今、一番臭いなーと思っている所がIC1の68000に繋がっている4Mメモリー(IC5〜8)のC10〜13のVIA です。
ルーペで観察していて、緑色に変色しているVIAがありました。
次回、それを修復してからテストしてみます。
あと、別件で32XのACアダプタの電圧測定と、内部コンデンサの交換を行います。
メガCDを外した状態と接続した状態で32Xソフトが止まる現象とメガCDの動作変化も確認できてまして、どうもタワー状態だとグランドが共通って所から32Xの電源に引っ張られている可能性が出てきました。(以前の32Xの悪さの原因がこれの可能性)
Posted by at 2020年08月10日 18:58
営様^^
お疲れ様です!
今日は暑いですねぇ、表にでれないぐらい暑い。。。

なんと、また症状が戻ってしまったようで^^;;
電源入れるたびに症状が変わる、うーん((+_+))


>緑色に変色しているVIAがありました
それ超怪しいですね。。。
漏れて乾いて緑色に変色という感じかもしれませんね。

更に32Xソフトが止まる現象ですか・
繋ぐと確かにグランドがすべて共通するので引っ張られるのは確かでしょうね。。。
それとグランドのどこかが腐食していて止まるとかも考えられます。
Posted by はにはに at 2020年08月11日 20:22
( ゜Д゜)ゞ お疲れ様です
今回は4メガメモリーの内、3枚が密集している所のコンデンサVIA修復を5つほど行いました。
結果は上々で雲の絵でOPが流れる状態で固定され変化する事が無くなりました。
狙いは有っていたようなので、残り1枚のコンデンサ付近のVIA修復を今度やってみようと思います。
他にもBOOTROM付近やPCM音源付近にも気になるVIAが有ったんですが、とりあえず症状改善を目標とします(パターンが不明なので関係している可能性は常に考慮します)
VIA修復には、やはり0.4oのピンバイスが丁度イイですね。手で回すと多少ブレるので0.5oスズメッキ線が丁度通る穴が開けられ、VIAも削れてないようです。

他、32XのACアダプタは電圧低下は無かったですが他のと同じ16V3300μFだったので手持ちの物で交換しました。
トップが膨らんでいて電解液なのかな?茶色い何かが基盤とコンデンサ本体に付いてました。(付き方からしてボンドか何か?かも知れません)
Posted by at 2020年08月16日 22:22
σ(・ω・`;)うーん・・・
少しエージングしてたら症状が変わってきました。
アクセスランプも点かず黒い画面のまま音も無しっていう、死んだ状態が多いですが、たまにアクセスランプが点いたり雲の画面だけ出たりするので死んではいない様子。

これはBOOT ROM付近のVIAも臭くなってきました。
エージングして症状が変わると言うことは、温まる事で基盤のVIAもしくは半田が膨張なりして割れるって事だと思われます。

とりあえず次回からコンデンサ付近のVIAを順を追って修復していきます。
最初は68000の4Mメモリー付近のVIAを終わらせてテスト、次はBOOT ROM付近のVIAを終わらせてテストって感じですかねえ。
手ごたえは確実に出てきているので、またご報告します。
Posted by at 2020年08月16日 23:22
営様^^
お疲れ様です。
VIAかまたはその半田が怪しいようで^^;
VIA修復に0.4oのピンバイス良いようで、
私も参考にさせて頂きますね。
また何か進展がありましたら教えてください。

Posted by はにはに at 2020年08月16日 23:49
( ゜Д゜)ゞ お疲れ様です
十分に冷やしてから再起動しましたら、やはりエージング前の雲の画でOPが流れる状態に戻っていました。
と言うことは、想像はおおむね合っていたって事なので、予定通りに進めて行こうと思います。
中々に良いデータが取れてきているので、何か進展しましたら改めて御報告しますね。
Posted by at 2020年08月17日 04:21
営様^^
ホントにお疲れ様です。

私の方はFM77AV40EXの電源が4級塩で液漏れしまくりで、色々な部品が侵食されて電源が入らす画面すら拝めずでショックでした。。。

メガCDは私も冷やしてから起動すると正常に動くということがあったのを思い出しました。。。
でも長時間動かすとすぐにフリーズです。
結局基板をリレークリーナーで綺麗にしたら正常に動くようになった記憶が。。
懲りずに修理頑張ってくださいね^^
Posted by はにはに at 2020年08月19日 01:19
( ゜Д゜)ゞ お疲れ様です
68000の4Mメモリー最後の一枚でC11付近のVIA二ヵ所、BOOT ROM付近のVIA二ヵ所を処置しました。
あと、IC19(日立製HC112)付近に臭いVIAが二ヵ所あったんですが、今回は清掃だけして様子見。IC19に関するVIAは動かなかった場合にやってみます。役割としてはメガドライブから受け取ったRAS2と言う信号を50MHzの水晶発振子のタイミングに合わせてIC2のメガCDエンジンに印加するっぽいです。

メモリー周りが臭いなあと思っていたので先日購入した拡大ルーペ×15倍で半田面の怪しい所を見て行ったんですが、1M bit WORD RAM 0/1(IC11/12)の半田で山の中に段差(横線)が入っている所が三か所くらい確認出来ました。

(;゜Д゜)・・・まさかこれか?
と、思ったので1M bit WORD RAMは全て、4Mメモリーも怪しい足は全て半田を溶かし直しました。

今回はこれで持ち帰って動作テストしてみます。
Posted by at 2020年08月25日 18:29
(;゜Д゜) 追記です
念のためサブボードも確認してみました。
拡大ルーペで確認した所、TR4の足が割れているようです。
これの役割は、メガドライブの電源が入るとTR3に入り、それに引っ張られるように電源を送り出すと言うもので、これがVCCやVCC2を作り出します。
(早い話がメガCDの電源トリガーですな)
エージングして死ぬ原因はこれっぽいです。
Posted by at 2020年08月25日 18:48
(´Д`)今回ダメだった場合・・・
IC19のVIAを修復し、それでもダメだったなら全部のメモリーの接続をテスターで確認していこうと思います。
まあ、回路図はあるので可能では有るのですが、手間がすごいですからね。
でも、必ず直します!
Posted by at 2020年08月25日 20:41
営様^^
お疲れ様です!
なんと...TR4の足が割れていたのですか^^;
>IC19のVIAを修復し、それでもダメだったなら全部
>のメモリーの接続をテスターで確認していこうと思>います。
手間がかかるでしょうけどこれにめげずに頑張ってくださいね。
Posted by はにはに at 2020年08月27日 18:18
( ゜Д゜)ゞ お疲れ様です
σ(・ω・`;)今回もダメでした・・・
TR4の件は、それはそれで当たっていたようです。
雲の静止画でOPが流れる状態は変わらずで、1時間エージングすると全く反応が無くなりますが、時間経過で雲の静止画だけ出ます。
本体の赤緑のLEDが点かなくなるので、ぱっと見は死んでいるように見えますが、時間経過で雲だけ出るので電源は行ってるのが確認できます。
LEDはIC2のメガCDから直接出てる信号で点くので、これが点かなくなるって言うことはIC2が止まってると見て、1M bit WORD RAM 0/1(IC11/12)の結線確認とIC19のVIAを修復してみます(RAS2という信号がIC2に行っているため)
エージングで変わると言うことは熱なんでしょうけど、SUBボードのヒートシンクの上に丁度1M bit WORD RAMが存在しているので、ここら辺と見て間違いないかな?と思っています。
Posted by at 2020年08月30日 12:32
(;゜Д゜)間違えました。
基盤のPDFを見てみたら、ヒートシンクの直上に有るのはSUBボードとの結線である21PINコネクタ付近でした。コネクタの半田割れを最初に当たってみます。
Posted by at 2020年08月30日 12:41
営様^^
ホントにお疲れ様です。
だいぶ苦戦してますねぇ^^;

>ヒートシンクの直上に有るのはSUBボードとの結線>である21PINコネクタ付近でした。コネクタの半田>割れを最初に当たってみます。

1つ1つやっていくしかないようですね^^;
Posted by はにはに at 2020年09月01日 17:00
( ゜Д゜)ゞ お疲れ様です
各ICの結線調査に入りました。今回は主に水晶発振子周りをやってます。
〇IC19の半田盛り直し
〇二階建ての発信子基盤が下がりすぎてIC2に触れそうだったので修正
〇21Pinコネクタと23Pinコネクタの半田盛り直し
特にSUBボードに繋がる21Pinコネクタは半田コテを当てると割れている時特有の「パチッ」って音がしたのでココはビンゴかと。(次回改めて半田吸い取り機でコネクタを外し、清掃してから付け直します)

結線関係は68000と4MRAMのアドレス線データ線(コントロール線は未調査。調べる為に色々な調査用ケーブルを自作しました)IC4のブートROMとメガドライブと繋がる60Pinコネクタとの接続は問題なかったです。
IC2のメガCDエンジンに繋がっている1M bit WORD RAM 0/1(IC11/12)の方が少しおかしく、各Pinがショートしているような結果が出ました。
これでは断線の判断が出来ないので、次回は1M bit WORD RAMを外してから、結線確認に入ります。

(^ー^;)まあ、今回もダメだったんですが、進展はしました。
最初の起動でバグった雲の画面が出て、一応スタートボタンで切り替わる所までいけました。
(参考ブログ https://bcc.hatenablog.com/entry/2019/06/02/150239
その後は今まで通りの雲の静止画でOPが流れる状態です。
ただ、1時間エージングした後の状態が少し変わりました。
OPが流れず雲の静止画で、本体ランプが緑だけって状態も出ますが、入れなおすと今まで通りの雲の静止画でOPが流れる状態で起動します。
と、言うことは21Pin辺りの当たりは正解だったと思われます。熱が加わるであろうLC8951の足も半田盛り直しを検討しています。
参考ブログ様のように1M bit WORD RAMの全てのPin結線を調査して修復が出来るかどうか?って所ですかね。おそらくIC11とIC12の間で電解液が浸透していてショートしている個所があるのではないか?と推察しています。
Posted by at 2020年09月07日 15:38
営様
ご苦労さまです^^

バグった雲がでてスタートで切り替わるところまでは行けたのですね^^
参考ブログ様のところは勉強になります!ありがとうございます。
そこまでやっても、まだ電解液が浸透してしまってる箇所があるようですね・・・^^;
Posted by はにはに at 2020年09月08日 00:28
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント: